Reports of issues from EasyPost

Incident Report for SKULabs

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 19:43 UTC

Monitoring

EasyPost has identified the issue and is working to resolve the matter. We are monitoring. You can read more on EasyPosts statuspage: https://www.easypoststatus.com/

See this article for advice: https://help.skulabs.com/en/articles/4424004

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Jul 23, 2026 - 16:40 UTC

Identified

EasyPost has reported internal networking issues impacting operations and is investigating: https://www.easypoststatus.com/

See this article for advice: https://help.skulabs.com/en/articles/4424004

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Jul 23, 2026 - 15:40 UTC

Investigating

We have reports of issues related from a shipping provider that may prevent or cause delays in retrieving rate quotes, purchasing shipping labels, voiding or manifesting shipments. We are investigating further.

EasyPost has provided a status update indicating issues as well: https://www.easypoststatus.com/

See this article for advice: https://help.skulabs.com/en/articles/4424004

You can sign up for text/call/email updates at https://skulabs.statuspage.io/
Posted Jul 23, 2026 - 15:08 UTC
This incident affected: Shipping (Third-Party Shipping Integrations, EasyPost API).